Clip trong arcgis 9.3

Thảo luận trong 'Giải đáp thắc mắc các phần mềm của ESRI' bắt đầu bởi diemnn, 4/5/12.

  1. diemnn

    diemnn New Member

    Tham gia ngày:
    1/3/12
    Bài viết:
    36
    Đã được thích:
    0
    Điểm thành tích:
    0
    Chào mọi người.Mình dùng toolbox CLip với input là input Giao_Thong_Line_polyline, clip là TD27124, xuất ra output.
    Nhưng sao đường viền của output lại bị hở.mặc dù đường viền này trong file input là kín. Mình không biết là kết quả output như vậy có chính xác ko. mặc dù mình dùng tool truyền tham số đầy đủ.
    Mọi người xem giúp mình nhé.
    thanks
     

    Các file đính kèm:

    Tags:
  2. asuspanda

    asuspanda New Member

    Tham gia ngày:
    27/10/11
    Bài viết:
    405
    Đã được thích:
    0
    Điểm thành tích:
    0
    Nghề nghiệp:
    Student
    Nơi ở:
    Nghệ An
    File gửi sai định dạng rồi. Cái đó chỉ mở được trong máy của bạn thôi. Nếu gửi thì bạn nên gửi các file liên quan thì mọi người mới giúp được chứ????.
    Bạn mô tả như vậy thì người giúp cũng chỉ đoán già đoán non thôi, chứ không có cơ sở chính xác được bạn à.
    Bạn nên nén và gửi 2 file Giao_Thong_Line_polyline và TD27124 lên mọi người sẽ có cách giúp bạn.
    Thân!!!.
    :p
     
  3. diemnn

    diemnn New Member

    Tham gia ngày:
    1/3/12
    Bài viết:
    36
    Đã được thích:
    0
    Điểm thành tích:
    0
  4. asuspanda

    asuspanda New Member

    Tham gia ngày:
    27/10/11
    Bài viết:
    405
    Đã được thích:
    0
    Điểm thành tích:
    0
    Nghề nghiệp:
    Student
    Nơi ở:
    Nghệ An
    Mình đã xem file của bạn và thấy nó không hoàn toàn trùng khớp. Đường GT có nơi nằm hoàn toàn ở ngoài TD27124 nên khi clip sẽ bị mất. Bạn có thể set tỷ lệ 1: 20 ở những chỗ bị ngắt là thấy ngay.
    Capture.JPG
    Nhưng điều may mắn là chỗ thiếu không nhiều ( khoảng 20 đoạn), vậy bạn có thể sửa dữ liệu trước rồi clip sau hoặc clip rồi sửa sau cho phù hợp là được.
    Thân!!!.
     
  5. misstuong

    misstuong New Member

    Tham gia ngày:
    16/1/12
    Bài viết:
    70
    Đã được thích:
    0
    Điểm thành tích:
    0
    Em cũng có 1 vấn đề đang mắc liên quan tới công cụ Clip nên xin phép được hỏi ở đây luôn.
    Em có các .shp của dữ liệu 1 tỉnh, khi mở thì không bị lỗi font chữ gì cả, nhưng sau khi Clip để lấy dữ liệu của 1 huyện, thì file_Clip của huyện đó lại bị lỗi hết font mà em không biết phải sửa làm sao. Mong được giúp sớm :(
    trước Clip
    1.jpg
    Sau Clip
    2.jpg

    Nếu như lúc lựa chọn Save file Clip em để save mặc định ở ArcGIS\Default.gdb\ thì không bị lỗi font gì hết, nhưng cứ chuyển file sang chỗ khác là bị lỗi ngay
     
  6. ninomax

    ninomax Moderator

    Tham gia ngày:
    21/10/11
    Bài viết:
    213
    Đã được thích:
    1
    Điểm thành tích:
    0

    Copy đoạn sau rồi lưu vào 1 file, đặt tên là caigicungduoc.reg
    Sau đó chạy file đó, nhấp OK . Khởi động lại ArcGIS là ok
     
  7. misstuong

    misstuong New Member

    Tham gia ngày:
    16/1/12
    Bài viết:
    70
    Đã được thích:
    0
    Điểm thành tích:
    0
    Anh ninomax ơi, không được anh ạ! Em đã làm y như anh hướng dẫn nhưng k có tác dụng gì anh ơi,còn cách không anh? chỉ cho em với :((
     
  8. gem1101

    gem1101 Member

    Tham gia ngày:
    9/2/12
    Bài viết:
    163
    Đã được thích:
    0
    Điểm thành tích:
    16
  9. asuspanda

    asuspanda New Member

    Tham gia ngày:
    27/10/11
    Bài viết:
    405
    Đã được thích:
    0
    Điểm thành tích:
    0
    Nghề nghiệp:
    Student
    Nơi ở:
    Nghệ An
    Misstuong có thể gửi dữ liệu lỗi cho mọi người test được không?. :D
     
  10. NguyenTuan

    NguyenTuan Member

    Tham gia ngày:
    21/10/11
    Bài viết:
    414
    Đã được thích:
    1
    Điểm thành tích:
    16
    Bạn gem1101 chịu khó nghiên cứu tutorial quá. Hixxx. Nếu một phần mềm mà nghiên cứu được phần tutorial như bạn gem thì kiến thức sẽ rất chắc. Bây giờ tìm kiếm tài liệu tiếng Việt thì sẽ rất hạn chế.
     
  11. gem1101

    gem1101 Member

    Tham gia ngày:
    9/2/12
    Bài viết:
    163
    Đã được thích:
    0
    Điểm thành tích:
    16
    ko ạ, cái này bản chất cũng là giống của a ninomax thôi, e chỉ đưa ra cho bạn misstuong tham khảo thêm thôi ạ
     
  12. misstuong

    misstuong New Member

    Tham gia ngày:
    16/1/12
    Bài viết:
    70
    Đã được thích:
    0
    Điểm thành tích:
    0
    Hic. Nhưng mà đọc xong rồi thì em vẫn chưa khắp phục được lỗi mấy anh ạ. Thông minh nghèo quá :(
     

Chia sẻ trang này

Share
Đang tải...