Làm sao để polyline không bị gãy nét

Thảo luận trong 'Giải đáp thắc mắc các phần mềm: ArcGIS, ArcView 3.' bắt đầu bởi tuhocgis, 24/5/12.

  1. tuhocgis

    tuhocgis New Member

    Tham gia ngày:
    9/3/12
    Bài viết:
    56
    Đã được thích:
    0
    Điểm thành tích:
    0
    Mình có file polyline bị gãy nét như hình:

    [​IMG]

    ko biết làm sao để nó hết bị gãy như thế và thành 1 đường thẳng hoặc cong cũng được. Có cách nào để sửa 1 lần tất cả các đường không?
    Bị gãy nét như vậy khi thể hiện đường ranh giới các vùng thì không thể hiện được toàn bị nhòe đường ranh giới đi
     
    Last edited by a moderator: 24/5/12
    Tags:
  2. hngialai

    hngialai Member

    Tham gia ngày:
    26/11/11
    Bài viết:
    254
    Đã được thích:
    6
    Điểm thành tích:
    18
    Bác hỏi hay "show hàng" để quảng cáo vậy
     
  3. tuhocgis

    tuhocgis New Member

    Tham gia ngày:
    9/3/12
    Bài viết:
    56
    Đã được thích:
    0
    Điểm thành tích:
    0
    theo bác thì em quảng cáo gì vậy?
     
  4. gem1101

    gem1101 New Member

    Tham gia ngày:
    9/2/12
    Bài viết:
    326
    Đã được thích:
    0
    Điểm thành tích:
    0
    theo mình hiểu có phải ý bạn là xuất ra ảnh, các đường line nó gãy khúc như vậy phải ko ?
     
  5. Amind1010

    Amind1010 Member

    Tham gia ngày:
    1/11/11
    Bài viết:
    124
    Đã được thích:
    0
    Điểm thành tích:
    16
    Bạn vẽ một đường thẳng sau đó bạn phóng to và thu nhỏ xem kết quả thế nào.
     
  6. tuhocgis

    tuhocgis New Member

    Tham gia ngày:
    9/3/12
    Bài viết:
    56
    Đã được thích:
    0
    Điểm thành tích:
    0
    ko bạn ah`. Mình mở bản đồ trên arcmap phóng to lên là nó bị gãy như vậy.

    ---------- Post added at 09:33 PM ---------- Previous post was at 09:33 PM ----------

    Mình đã thử vẽ. Vẽ theo các hướng khác nhau thì nó bị gãy khác nhau. Có 1 hướng nó liền mạch ko bị gãy như hình trên.
     
  7. gem1101

    gem1101 New Member

    Tham gia ngày:
    9/2/12
    Bài viết:
    326
    Đã được thích:
    0
    Điểm thành tích:
    0
    ko xuất ra thì can dự gì, nó là vector thì kệ nó thôi, tưởng bạn muốn xuất ra bản đồ mà sợ nó gãy khúc ko đẹp mới phải xử lý chứ
     
  8. hngialai

    hngialai Member

    Tham gia ngày:
    26/11/11
    Bài viết:
    254
    Đã được thích:
    6
    Điểm thành tích:
    18
    Cái chữ "BMTER.COM" trên tấm ảnh bạn đính kèm là gì vậy bạn ?
     
  9. gem1101

    gem1101 New Member

    Tham gia ngày:
    9/2/12
    Bài viết:
    326
    Đã được thích:
    0
    Điểm thành tích:
    0
    tớ thấy bạn ấy hỏi như thế có vấn đề gì đâu, chữ đấy thì sao?
     
  10. tuhocgis

    tuhocgis New Member

    Tham gia ngày:
    9/3/12
    Bài viết:
    56
    Đã được thích:
    0
    Điểm thành tích:
    0
    Nhưng mà khi mình thay đổi symbol cho nó (vì là đường ranh giới) khi thay đổi nó hiện ra hình thế này:
    [​IMG]

    Mình có file ranh giới phường, quận, huyện khi đổi symbol thì nó bị nhòe đường đi như vậy nhìn rất xấu. không biết có cách nào khắc phục không.
    P/s: bạn thấy đó chỗ thì rõ chỗ thì không rất khó coi

    ---------- Post added at 10:20 PM ---------- Previous post was at 10:18 PM ----------

    Ah` đó là do mình up ảnh lên trang up.bmter.com nên nó dán hình đó vào. Chỉ có vậy thôi mà bạn cũng lăn tăn sao?
     
  11. gem1101

    gem1101 New Member

    Tham gia ngày:
    9/2/12
    Bài viết:
    326
    Đã được thích:
    0
    Điểm thành tích:
    0
    cái này, có lẽ phải xem cậu làm thế nào thì mới biết dc, có thể do ký hiệu thiết kế , cậu thử thiết kế ký hiệu mới xem nó có bị thế ko
     
  12. tuhocgis

    tuhocgis New Member

    Tham gia ngày:
    9/3/12
    Bài viết:
    56
    Đã được thích:
    0
    Điểm thành tích:
    0
    Mình đã thử thiết kế ký hiệu mới rồi vẫn bị vậy. Kể cả khi để 1 đường thẳng thì khi lên hành đó nó cũng gãy ra như bạn thấy trên ảnh đó.
     
  13. ko_ni_chi

    ko_ni_chi New Member

    Tham gia ngày:
    20/10/11
    Bài viết:
    584
    Đã được thích:
    0
    Điểm thành tích:
    0
    Nghề nghiệp:
    Môi trường
    Nơi ở:
    DakLak-HCM
    Tưởng bạn quảng cáo cái gì chứ @@ chắc anh Nghị cũng hiểu nhầm
     
  14. nt2008

    nt2008 New Member

    Tham gia ngày:
    21/10/11
    Bài viết:
    136
    Đã được thích:
    0
    Điểm thành tích:
    0
    Lỗi này là do khi số hóa đặt quá nhiều vertex (đỉnh). Bạn thử bật chế độ biên tập rồi click đúp vào đối tượng thì sẽ thấy xanh lè :p

    Dùng công cụ Simplify của ArcGIS để giảm thiểu vertex nhé!
     
  15. tuhocgis

    tuhocgis New Member

    Tham gia ngày:
    9/3/12
    Bài viết:
    56
    Đã được thích:
    0
    Điểm thành tích:
    0
    Bạn ơi mình dùng công cụ đó chọn nhưng nó không giảm là sao nhỉ?
    Cái phần Simlification Tolerance nên chọn giá trị là bao nhiêu? Sao mình thử rất nhiều giá trị rồi mà nó không giảm đi nhi? (để giá trị càng lớn thì sẽ giảm được nhiều hay càng nhỏ sẽ giảm được nhiều?)
    [​IMG]
     
    Last edited by a moderator: 25/5/12

Chia sẻ trang này

Share
Đang tải...