Lỗi khi sử dụng chức năng split

Thảo luận trong 'Giải đáp thắc mắc các phần mềm của Pitney Bowes' bắt đầu bởi anhbagiau, 24/2/12.

  1. anhbagiau

    anhbagiau New Member

    Tham gia ngày:
    23/2/12
    Bài viết:
    3
    Đã được thích:
    0
    Điểm thành tích:
    0
    Untitled.jpg Em mới học mapinfo,nhưng khi đến bài thực hành dùng split để cắt đường theo các ô lưới,nhưng khi split thì nó lại hiện lỗi như hình,các anh,các bác có ai biết cách khắc phục thì chỉ e với,e xin chân thành cám ơn ạ! Untitled.jpg
     

    Các file đính kèm:

    Last edited by a moderator: 24/2/12
    Tags:
  2. asuspanda

    asuspanda New Member

    Tham gia ngày:
    27/10/11
    Bài viết:
    405
    Đã được thích:
    0
    Điểm thành tích:
    0
    Nghề nghiệp:
    Student
    Nơi ở:
    Nghệ An
    Ảnh mờ quá không đọc được lỗi. bạn xem lại:
    - Đối tượng đường là đối tượng cần cắt, thì phải chọn đối tượng này để set target, rồi mới chọn đối tượng cắt để split.
    - Bạn vẽ lại một đối tượng dạng vùng trùng với 4 khung của Grid, sau đó dùng nó để cắt là ok.
     
  3. anhbagiau

    anhbagiau New Member

    Tham gia ngày:
    23/2/12
    Bài viết:
    3
    Đã được thích:
    0
    Điểm thành tích:
    0
    e xin gửi hình lại ạ,e đã làm theo các bước 1 cách cẩn thận nhưng khi split xong thì nó lại hiện lỗi : Untitled1.jpg
     
  4. ninhbinhquetoi

    ninhbinhquetoi New Member

    Tham gia ngày:
    29/10/11
    Bài viết:
    336
    Đã được thích:
    2
    Điểm thành tích:
    0
    Nếu tách hay cắt thì cũng chọn đối tượng sẽ tác động chon set target và chọn đối trượng sẽ lấy làm gianh giới tách và split.
    Nên nhớ điều cơ bản là file .tab nào bị tác động thì sẽ phải để ở chế độ edit.
    hơn nữa mình thầy bạn dùng lưới để làm ranh giới cắt thì Mapinfo nó biết cắt kiểu gì nhỉ. Mình thường dùng 1 đối tượng là vùng (vùng chỉ ra ranh giới cắt) để cắt. Chẳng dùng lưới để cắt bao giờ cả.
     
    Last edited by a moderator: 25/2/12
  5. asuspanda

    asuspanda New Member

    Tham gia ngày:
    27/10/11
    Bài viết:
    405
    Đã được thích:
    0
    Điểm thành tích:
    0
    Nghề nghiệp:
    Student
    Nơi ở:
    Nghệ An
    Bạn gửi 2 lớp đó lên để mọi người test thử nhé.
    Chưa gặp lỗi này bao giờ cả. Nếu bạn đã làm từng bước cẩn thận mà vẫn lỗi vậy thì có lẽ lỗi nằm ở trong dữ liệu hoặc hệ thống phần mềm của bạn.
     
  6. anhbagiau

    anhbagiau New Member

    Tham gia ngày:
    23/2/12
    Bài viết:
    3
    Đã được thích:
    0
    Điểm thành tích:
    0
    Do phần này mình mún thực hiện làm 1 workspace về mật độ giao thông của thành phố hồ chí minh,trong đó,mỗi ô lưới sẽ diễn tả mật độ giao thông của ô đó,ví dụ 1 ô nó có nhiều đường thì sẽ cộng các chiều dài của tất cả các đường trong ô đó để thể hiện mật độ giao thông,màu của ô sẽ biểu diễn dc mật độ giao thông nhiều hay ít.Vấn đề ở đây là mình mún hỏi các bạn là cách giải quyết lỗi này,bởi vì cùng 1 nguồn dữ liệu nhưng khi thao tác trên máy mình thì lại hiện lỗi như vậy,trong khi các máy tính của các bạn cùng khoá thì lại làm được,mình cũng nhấn mạnh là cũng đã có bạn trong lớp bị lỗi giống mình,trong khi cùng 1 bản cài đặt,cùng 1 nguồn dữ liệu mà máy làm được máy lại không làm được.
    Dù sao mình cũng cám ơn bạn,tại mình không hiểu được lỗi này nên mún hỏi các bạn,các anh đi trước,đã từng học qua để e giải quyết nó tốt hơn!

    ---------- Post added at 01:49 PM ---------- Previous post was at 01:44 PM ----------

    cái này là do phần mình học thực hành dùng lưới để cắt đó bạn,bởi vì mỗi ô lưới cũng là 1 vùng mà,nhưng k hiểu sao mình đã làm rất cẩn thận mà vẫn hiện lỗi,nếu bạn đã từng gặp qua lỗi này thì có thể giúp mình,chứ về vấn đề dữ liệu vs phương pháp thì bạn mình đã làm ở máy khác,đều ok hết,vấn đề ở đây là có máy làm được và có máy không làm được phần này,mình đặt câu hỏi mong muốn ai đã từng gặp lỗi này thì hướng dẫn giúp mình,Mình xin chân thành cám ơn.
     

Chia sẻ trang này

Share
Đang tải...